Puppet module for TranSMART

Build: #86 failed Changes by phozzy <arthur.fayzullin@gmail.com>

Build result summary

Details

Completed
Duration
32 seconds
Labels
None
Agent
Default Agent
Revision
3e19b6161a9b6fdbaef0f30af3d5fee03e8cdf6c 3e19b6161a9b6fdbaef0f30af3d5fee03e8cdf6c
Failing since
#84 (Changes by Ewelina Grudzień)

No failed tests found, a possible compilation error occurred.

Responsible

Code commits

Author Commit Message Commit date
phozzy <arthur.fayzullin@gmail.com> phozzy <arthur.fayzullin@gmail.com> 3e19b6161a9b6fdbaef0f30af3d5fee03e8cdf6c 3e19b6161a9b6fdbaef0f30af3d5fee03e8cdf6c Fix 2 typo errors

Error summary for Rake tests

The job generated some errors, drill down into the full build log for more details.

gpg: requesting key D39DC0E3 from hkp server keys.gnupg.net
gpg: key D39DC0E3: "Michal Papis (RVM signing) <mpapis@gmail.com>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
Already installed ruby-2.3.3.
To reinstall use:

    rvm reinstall ruby-2.3.3

Unknown ruby interpreter version (do not know how to handle): >=2.3.0.
Unknown ruby interpreter version (do not know how to handle): >=2.3.0.
---> syntax:manifests
---> syntax:templates
---> syntax:hiera:yaml
puppet parser validate --noop manifests/solr.pp
puppet parser validate --noop manifests/data.pp
puppet parser validate --noop manifests/batch.pp
puppet parser validate --noop manifests/complete.pp
puppet parser validate --noop manifests/essentials.pp
puppet parser validate --noop manifests/rserve.pp
puppet parser validate --noop manifests/database.pp
puppet parser validate --noop manifests/thehyve_repositories.pp
puppet parser validate --noop manifests/api_essentials.pp
puppet parser validate --noop manifests/backend.pp
puppet parser validate --noop manifests/config.pp
puppet parser validate --noop manifests/init.pp
puppet parser validate --noop manifests/params.pp
ruby -c spec/classes/data_spec.rb
ruby -c spec/classes/init_spec.rb
ruby -c spec/classes/backend_spec.rb
ruby -c spec/classes/config_spec.rb
ruby -c spec/hosts/test_spec.rb
ruby -c spec/spec_helper.rb
erb -P -x -T '-' templates/config/batchdb.properties.erb | ruby -c
erb -P -x -T '-' templates/config/transmart-api-server/config.yml.erb | ruby -c
erb -P -x -T '-' templates/config/transmart-server/application.groovy.erb | ruby -c
erb -P -x -T '-' templates/config/transmart-server/config.groovy.erb | ruby -c
erb -P -x -T '-' templates/config/transmart-server/datasource.groovy.erb | ruby -c
erb -P -x -T '-' templates/config/tsdata-vars.erb | ruby -c
erb -P -x -T '-' templates/service/transmart-rserve.service.erb | ruby -c
erb -P -x -T '-' templates/service/transmart-server.service.erb | ruby -c
erb -P -x -T '-' templates/service/transmart-solr.service.erb | ruby -c
erb -P -x -T '-' templates/solr.erb | ruby -c
erb -P -x -T '-' templates/transmart-batch.erb | ruby -c
erb -P -x -T '-' templates/start.erb | ruby -c
I, [2019-07-10T15:27:37.139439 #29620]  INFO -- : Creating symlink from spec/fixtures/modules/transmart_core to /opt/bamboo/bamboo-home/xml-data/build-dir/PUPPET-PUPPETTS-JOB1/transmart_core
Failed to retrieve Augeas version: cannot load such file -- augeas

Deprecation Warnings:

puppetlabs_spec_helper: defaults `mock_with` to `:mocha`. See https://github.com/puppetlabs/puppetlabs_spec_helper#mock_with to choose a sensible value for you


If you need more of the backtrace for any of these deprecations to
identify where to make the necessary changes, you can configure
`config.raise_errors_for_deprecations!`, and it will turn the
deprecation warnings into errors, giving you the full backtrace.
/opt/bamboo/bamboo-home/.rvm/rubies/ruby-2.3.3/bin/ruby -I/opt/bamboo/bamboo-home/.rvm/gems/ruby-2.3.3/gems/rspec-core-3.8.2/lib:/opt/bamboo/bamboo-home/.rvm/gems/ruby-2.3.3/gems/rspec-support-3.8.2/lib /opt/bamboo/bamboo-home/.rvm/gems/ruby-2.3.3/gems/rspec-core-3.8.2/exe/rspec --pattern spec/\{aliases,classes,defines,functions,hosts,integration,plans,tasks,type_aliases,types,unit\}/\*\*/\*_spec.rb failed